NEW T3X NOT EJECTING BRASS

Improving and repairing firearms. Rifle bedding, barrel work, stock replacement and other ways to improve your firearms.

Re: NEW T3X NOT EJECTING BRASS

Post by brett1868 » 02 Feb 2019, 1:53 pm

Yay...I helped :) That's my good deed done for the year.

Report back once you talk to the shop as I'd be interested to hear how they handle this.
How's my posting?
Complaints, Concerns - 13 11 14
User avatar
brett1868
Lieutenant General
Lieutenant General
 
Posts: 3364
New South Wales

Re: NEW T3X NOT EJECTING BRASS

Post by JimTom » 02 Feb 2019, 2:24 pm

Nice work mate. Nailed it. :thumbsup:
Shoot straight you bastards, don’t make a mess of it
User avatar
JimTom
Second Lieutenant
Second Lieutenant
 
Posts: 776
-

Re: NEW T3X NOT EJECTING BRASS

Post by selaga » 03 Feb 2019, 7:36 am

Update. Gun shop did the right thing and luckily it was sorted. Bolt was off a T3 300 winnag they they had on lay-bys at their other store. All numbers matched across both rifles and bolts combos. New bolt is T3X with metallic shroud.

If they didn’t find matching bolt they offered a new rifle and to take care of paperwork.

Owner came and saw me and was clearly pissed about what happened.

As a final gesture they gave me couple of boxes of ammo.

Happy Chappy now.
selaga
Private
Private
 
Posts: 20
New South Wales

Re: NEW T3X NOT EJECTING BRASS

Post by JimTom » 03 Feb 2019, 7:56 am

Pretty bloody average mate, nevertheless, mistakes do happen and at least they did the right thing and chucked in a sweetener on top.
Shoot straight you bastards, don’t make a mess of it
User avatar
JimTom
Second Lieutenant
Second Lieutenant
 
Posts: 776
-

Re: NEW T3X NOT EJECTING BRASS

Post by Chronos » 03 Feb 2019, 8:25 am

Is a dealer stuff up not a factory thing. Dealer should be able to run the last 3 numbers through their registry computer and find the other gun and probably your bolt.

Chronos
.177 pellets through to .416 Ruger
User avatar
Chronos
Brigadier
Brigadier
 
Posts: 2286
New South Wales

Re: NEW T3X NOT EJECTING BRASS

Post by marksman » 03 Feb 2019, 11:21 am

selaga wrote:Update. Gun shop did the right thing and luckily it was sorted. Bolt was off a T3 300 winnag they they had on lay-bys at their other store. All numbers matched across both rifles and bolts combos. New bolt is T3X with metallic shroud.

If they didn’t find matching bolt they offered a new rifle and to take care of paperwork.

Owner came and saw me and was clearly pissed about what happened.

As a final gesture they gave me couple of boxes of ammo.

Happy Chappy now.


very cheap fix for the gun shop owner :wtf:
may have been a good doctors bill and a new rifle :drinks:
the RO at the range should have picked it up :thumbsup:
User avatar
marksman
Major
Major
 
Posts: 1677
Victoria

Re: NEW T3X NOT EJECTING BRASS

Post by bigfellascott » 03 Feb 2019, 11:26 am

Good to hear it got sorted mate.
User avatar
bigfellascott
Field Marshal
Field Marshal
 
Posts: 5401
-

Re: NEW T3X NOT EJECTING BRASS

Post by ponkychonk » 03 Feb 2019, 3:22 pm

Just checked my bolt serial number as well due to Homer's advice; mine match so will assume it is in fact a dodgy ejector.
.177Air
.22
.223
.357/.38SP
7.62x54R
8MM Mauser
.303 British
.410bore Lever
12GA Lever
12GA Coach
7.62x38mmR
ponkychonk
Lance Corporal
Lance Corporal
 
Posts: 87
Other

Re: NEW T3X NOT EJECTING BRASS

Post by bigfellascott » 03 Feb 2019, 4:05 pm

ponkychonk wrote:Just checked my bolt serial number as well due to Homer's advice; mine match so will assume it is in fact a dodgy ejector.


How olds the rifle mate? if might just be a bit of brass stuck behind the ejector stopping it from working right. :thumbsup:
User avatar
bigfellascott
Field Marshal
Field Marshal
 
Posts: 5401
-

Re: NEW T3X NOT EJECTING BRASS

Post by ponkychonk » 04 Feb 2019, 4:53 pm

bigfellascott wrote:
ponkychonk wrote:Just checked my bolt serial number as well due to Homer's advice; mine match so will assume it is in fact a dodgy ejector.


How olds the rifle mate? if might just be a bit of brass stuck behind the ejector stopping it from working right. :thumbsup:


Absolutely brand new. Smith replaced the ejector and boom, works perfectly.
.177Air
.22
.223
.357/.38SP
7.62x54R
8MM Mauser
.303 British
.410bore Lever
12GA Lever
12GA Coach
7.62x38mmR
ponkychonk
Lance Corporal
Lance Corporal
 
Posts: 87
Other

Re: NEW T3X NOT EJECTING BRASS

Post by marksman » 04 Feb 2019, 6:04 pm

good to see you have it sorted :thumbsup:
User avatar
marksman
Major
Major
 
Posts: 1677
Victoria

Re: NEW T3X NOT EJECTING BRASS

Post by JimTom » 04 Feb 2019, 6:16 pm

Glad to hear mate
Shoot straight you bastards, don’t make a mess of it
User avatar
JimTom
Second Lieutenant
Second Lieutenant
 
Posts: 776
-

Re: NEW T3X NOT EJECTING BRASS

Post by bigfellascott » 04 Feb 2019, 9:21 pm

ponkychonk wrote:
bigfellascott wrote:
ponkychonk wrote:Just checked my bolt serial number as well due to Homer's advice; mine match so will assume it is in fact a dodgy ejector.


How olds the rifle mate? if might just be a bit of brass stuck behind the ejector stopping it from working right. :thumbsup:


Absolutely brand new. Smith replaced the ejector and boom, works perfectly.


:thumbsup:

What was the problem with the ejector?
User avatar
bigfellascott
Field Marshal
Field Marshal
 
Posts: 5401
-

Re: NEW T3X NOT EJECTING BRASS

Post by ponkychonk » 05 Feb 2019, 11:00 am

bigfellascott wrote:
ponkychonk wrote:
bigfellascott wrote:
ponkychonk wrote:Just checked my bolt serial number as well due to Homer's advice; mine match so will assume it is in fact a dodgy ejector.


How olds the rifle mate? if might just be a bit of brass stuck behind the ejector stopping it from working right. :thumbsup:


Absolutely brand new. Smith replaced the ejector and boom, works perfectly.


:thumbsup:

What was the problem with the ejector?


No idea. Gunsmith said it looked fine but was just not working at all. Put a new one in and its working again.
.177Air
.22
.223
.357/.38SP
7.62x54R
8MM Mauser
.303 British
.410bore Lever
12GA Lever
12GA Coach
7.62x38mmR
ponkychonk
Lance Corporal
Lance Corporal
 
Posts: 87
Other

Re: NEW T3X NOT EJECTING BRASS

Post by Diddums » 06 Feb 2019, 10:04 pm

When I bought my T3x 22-250 it wouldn't extract cases from the first shot.
I found there to be the smallest piece of metal filingings behind the extractor claw and was stopping it from gripping the case properly.
Blasted it with some brake cleaner and it was all good, hasn't missed a beat since.

Seems like there is a bit of a QC issue with Tikka.
Diddums
Lance Corporal
Lance Corporal
 
Posts: 95
New South Wales

Previous

Back to top
 
Return to Gunsmithing